Welcome to the New PrimeBuy.com We've upgraded our store to make finding and ordering the equipment you need faster and easier. If anything gets in the way of your order, or you notice something that isn't working as it should, let us know through live chat or email. A member of our team will help you and make sure it gets fixed. Thank you for choosing PrimeBuy

DECT IP Multi-Cell System
DECT IP Multi-Cell System
Yealink
DECT IP Multi-Cell System
DECT IP Multi-Cell System

Yealink W90B DECT IP Multi-Cell System

Brand: Yealink
Part #:
W90B
Condition:
Brand New
$381.50 /Kit
$479.00 You save $97.50 20%
Free shipping
$381.50 /Kit
$479.00 You save $97.50 20%

Notification

This product will be drop-shipped directly from the manufacturer. We will provide you with the manufacturer's lead time once advised.

Manufacturer warranty

Description

$381.50 /Kit
$479.00 You save $97.50 20%
Free shipping

Technical details

Main features
  • Interface 1 x RJ45 10/100M Ethernet port Power over Ethernet (IEEE 802.3af), Class 1
  • Security Open VPN Transport Layer Security (TLS) HTTPS (server/client), SRTP (RFC3711) Digest authentication Secure configuration file via AES encryption Support SHA256/SHA512/SHA384
  • Management Auto-provision via TFTP/FTP/HTTP/HTTPS/RPS Auto-provision with PnP Handset upgrade: OTA (Over-The-Air) Configuration: browser/phone/auto-provision Trace package and system log export
  • Network Features SIP v1 (RFC2543), v2 (RFC3261) SNTP/NTP VLAN (802.1Q and 802.1P) 802.1x, LLDP STUN Client (NAT Traversal) UDP/TCP/TLS IP assignment: Static/DHCP Support outbound proxy server backup
  • Audio Features Full-duplex speakerphone Hearing Aid Compatibility (HAC) compliant DTMF Wideband codec: Opus, AMR-WB (optional), G.722 Narrowband codec: AMR-NB (optional), PCMU,PCMA, G.726, G.729, iLBC VAD, CNG, AGC, PLC, AJB
  • Physical Features Indoor Range: 30m˜50m (The ideal distance is 50m) Outdoor Range: 300m (in ideal conditions) Wall mountable Three LED indicators on W90DM/W90B: - 1 x LAN (Power Indicator & Network Status) LED - 1 x Role LED - 1 x DECT LED - External Yealink AC adapter: AC 100-240V Input and DC 5V/1.2A Output - Color: Pearl White - Dimension: 134mm x 100mm x 28mm - Operating humidity: 10˜95% - Operating temperature: 0˜+40°C (+32˜104°F)
  • DECT Frequency bands: 1880 - 1900 MHz (Europe), 1920 - 1930 MHz (US) DECT Standards: CAT-iq2.0

Related items.

Customers buy together with this.

Reviews.

There are currently no reviews for this product. You can leave the first review and share your experience.

Your history.